django-arcgis-marketplace 0.0.9 2017-08-13 ✔ PY3

django-arcgis-marketplace on PyPI  

Arcgis marketplace app.


Authormongkok
LicenseMIT

Arcgis marketplace application.

Dependencies

  • Python ≥ 3.4
  • Django ≥ 1.11
  • Postgres

Installation

Install last stable version from Pypi.

pip install django-arcgis-marketplace

Add arcgis_marketplace to your INSTALLED_APPS setting.

INSTALLED_APPS = (
    ...
    'django_filters',
    'oauth2_provider',
    'paypal.standard.ipn',
    'polymorphic',
    'rest_framework',
    'social_django',
    'taggit',
    ...
    'core_flavor.apps.CoreAppConfig',
    'countries_flavor.apps.CountriesAppConfig',
    'orders_flavor.apps.OrdersAppConfig',
    'arcgis_marketplace.apps.ArcgisMarketplaceAppConfig'
)

Hook the Django urls into your URLconf.

from django.conf.urls import include, url

urlpatterns = [
    url(r'^', include(
        'arcgis_marketplace.urls',
        namespace='arcgis-marketplace')),

    url(r'^', include(
        'arcgis_marketplace.api.urls',
        namespace='arcgis-marketplace-api'))
]

Apply migrations.

python manage.py migrate